Zulu Community

Java error on application install

Updated on February 8, 2018 in Zulu on Mac OS X
1 on February 7, 2018

I am trying to install an application called OpenHAB, which recommends using ZULU. When I attempt to do this I receive the following error, I am not very savvy with UNIX?CLI so any information on what needs to be changed would help. I also noted when checking the version command that this current MacOSX (9.0.4)version does not report (build 1.X.X) as indicated in the install guide.

Last login: Wed Feb 7 10:47:33 on ttys000
ulwil-454-bs:~ administrator$ /Users/administrator/Downloads/openhab-2/start.sh
Launching the openHAB runtime…
Unable to find any JVMs matching version “1.8”.
Java 1.8 or higher is required. Aborting launch.
/Users/administrator/Downloads/openhab-2/runtime/bin/setenv: line 114: /bin/true: No such file or directory
ulwil-454-bs:~ administrator$ java -version
openjdk version “9.0.4.1”
OpenJDK Runtime Environment (Zulu build 9.0.4.1+11)
OpenJDK 64-Bit Server VM (Zulu build 9.0.4.1+11, mixed mode)
ulwil-454-bs:~ administrator$

  • Liked by
Reply
0 on February 8, 2018

Found my own answer:

At the moment openHAB is incompatible with Java 9. Install Zulu JDK 8 instead.

  • Liked by
Reply
Cancel